С 1 января Oculus Store перестанет принимать софт на Mobile SDK старше 1.0

0
173

Image_Samsung-Gear-VR_R-Perspective

Oculus закручивает гайки в платформе для разработчиков мобильной виртуальной реальности. Согласно записи в корпоративном блоге, с 1 января 2016 года магазин Oculus Store будет принимать только приложения, использующие Mobile SDK 1.0 или более поздний. Вышедший из бета-стадии Mobile SDK 1.0 для Gear VR был представлен в ноябре; он обозначил переход от экспериментального интерфейса к более зрелому, стабильному API, сосредоточенному на максимальной производительности.

Mobile SDK 1.0 также включает критическое улучшение по сравнению с предыдущими версиями: в нём большая часть функций отделена от клиентского приложения, то есть внедрена возможность доставлять системные обновления и добавлять функции без обновления приложений. В результате софт на SDK 1.0 оказывается намного более перспективным, чем на более ранних версиях платформы. Необходимость в омоложении платформы явилась причиной новых требований.

Также Oculus настоятельно рекомендует разработчикам, приложения которых уже поступили в Oculus Store, предоставить их обновления до SDK 1.0 как можно скорее, поскольку, несмотря на то, что старые версии платформы некоторое время продолжат работу, их поддержка не будет обеспечена в новых версиях Android. Сбои в приложениях потребуют снять их с витрины до получения обновлений.

В дополнение к более долгой перспективе коммерциализации приведение к SDK 1.0 может способствовать росту производительности и стабильности. Во многих случаях оно даже не потребует редактирования кода.

Вот некоторые рекомендации, которые могут помочь с переходом:

  • Если вы работаете в Unity 5, убедитесь в наличии пакета версии Unity 5.2.2p4 или новее. Разработчикам с Unity 4 потребуется использовать Oculus Legacy Integration для Unity 4 версии 0.8 или более поздней.
  • 
Поддержка Unreal Engine ожидается очень скоро — в версии движка 4.10.
  • Если вы работаете с другими движками, последние версии SDK для вас лежат здесь.
  • Если вы обновляетесь с очень старого SDK (до 0.6), убедитесь в соответствии AndroidManifest.xml, вышедшем в этом году.

Все вопросы предлагается задавать на форуме Oculus.

Далее: Oculus выпустила Audio SDK 1.0.1 и пакет звуков для виртуальной реальности

По материалам Oculus